HDU 1060  Leftmost Digit

   Leftmost Digit

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21744    Accepted Submission(s): 8408


 

Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

 

Output

For each test case, you should output the leftmost digit of N^N.

 

Sample Input


 

2 3 4

 

Sample Output


 
2 2

Hint

In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

题解:   {color{Red} n^{n}=a	imes 10^{x}
ightarrow lg\, n^{n}=x+lg\, a
ightarrow a=10^{nlgn-x}=10^{nlgn-(int)nlgn)}}

#include<iostream>
#include<string.h>
#include<algorithm>
#include<cmath>
#define ll long long
using namespace std;
int main()
{
        ll T;
        double n;
        scanf("%lld",&T);
        while(T--){
                scanf("%lf",&n);
                cout<<(ll)pow(10,n*log10(n)-(ll)(n*log10(n)))<<endl;
        }
        return 0;
}
原文地址:https://www.cnblogs.com/aeipyuan/p/10704475.html