KMP HDU 1686 Oulipo

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

看了一晚上kmp,翻了无数博客,原理明白了,但发现代码还不太懂,结果睡觉前回想了一下发现代码竟然已经背过了。。。一边回想一边搞懂了代码,纪念一下第一次手写ac的kmp
原理主要参考这个博客 http://www.cnblogs.com/SYCstudio/p/7194315.html
https://www.cnblogs.com/zhangtianq/p/5839909.html

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
int next[10005];
char str1[1000005],str2[10005];
int cnt;
void get_next()
{
    int i=0,j=-1;
    next[0]=-1;
    int len=strlen(str2);
    while(i<len)
    {
        if(j==-1||str2[i]==str2[j])
        {
            i++;
            j++;
            if(str2[i]==str2[j])
                next[i]=next[j];
            else
                next[i]=j;
        }
        else
            j=next[j];
    }
}
int kmp()
{
    get_next();
    int len1=strlen(str1);
    int len2=strlen(str2);
    int i=0,j=0;
    while(i<len1)
    {
        if(j==-1||str1[i]==str2[j])
        {
            i++;
            j++;
        }
        else
            j=next[j];
        if(j==len2)
        {
            cnt++;
            j=next[j];
        }
    }
}
int main()
{
    int t;
    cin>>t;
    getchar();
    while(t--)
    {
        cnt=0;
        gets(str2);
        gets(str1);
        kmp();
        cout<<cnt<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/acagain/p/9180733.html