POJ1163——The Triangle

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

这道题属于入门级DP,从下往上计算比较方便,递推公式F[i][j]=max{F[i+1][j],F[i+1][j+1]}+num[i][j],初始把最后一行数据赋给F数组,或者直接在num数组上计算。。。

Talk is cheap>>

package poj.dp;

import java.util.Scanner;

/**
 * Created with IntelliJ IDEA.
 * User: Blank
 * Date: 2015/4/2
 * Time: 20:42
 */
public class TheTriangle {
    public static void main(String[] sure) {
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        int[][] num = new int[n][n];
        int[][] cal = new int[n][n];
        int i = 0;
        while (i < n) {
            int j = 0;
            while (j <= i) {
                num[i][j] = sc.nextInt();
                j++;
            }
            i++;
        }
        for (int j = 0; j < n; j++) {
            cal[n-1][j]=num[n-1][j];
        }
        for (int j = n - 2; j >= 0; j--) {
            for (int k = n - 2; k >= 0; k--) {
                cal[j][k]=Math.max(cal[j+1][k],cal[j+1][k+1])+num[j][k];
            }
        }
        System.out.println(cal[0][0]);
    }
}
原文地址:https://www.cnblogs.com/aboutblank/p/4388401.html