Programming Ability Test学习 1031. Hello World for U (20)

1031. Hello World for U (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h   !
e   d
l   l
lowor

提交代码

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<string>
#include<algorithm> 
#include<map>
#define MAXSIZE 100005
typedef long long ll;

using namespace std;


//*******常用基本函数*******


//*******本题用到函数*******

//变为U
void varyU(char* s)
{
	int i,j,n1,n2,n3;
	int len = strlen(s);  
        n1 = (len + 2) / 3 ;  
        n2 = len - 2*n1;  
	for(i=0;i<n1-1;i++)
	{
		cout<<s[i];
		for(j=0;j<n2;j++)cout<<" ";
		cout<<s[strlen(s)-1-i]<<endl;
	}
	for(int k=i;k<len-i;k++)cout<<s[k];
	cout<<endl;
} 

int main()
{
	char ss[MAXSIZE];
    cin>>ss;
    varyU(ss);
    //cout<<ss[2]<<endl;
	return 0;
} 

  

原文地址:https://www.cnblogs.com/a842297171/p/4797701.html