POJ

"Let it Bead" company is located upstairs at 700 Cannery Row in Monterey, CA. As you can deduce from the company name, their business is beads. Their PR department found out that customers are interested in buying colored bracelets. However, over 90 percent of the target audience insists that the bracelets be unique. (Just imagine what happened if two women showed up at the same party wearing identical bracelets!) It's a good thing that bracelets can have different lengths and need not be made of beads of one color. Help the boss estimating maximum profit by calculating how many different bracelets can be produced.

A bracelet is a ring-like sequence of s beads each of which can have one of c distinct colors. The ring is closed, i.e. has no beginning or end, and has no direction. Assume an unlimited supply of beads of each color. For different values of s and c, calculate the number of different bracelets that can be made.
Input
Every line of the input file defines a test case and contains two integers: the number of available colors c followed by the length of the bracelets s. Input is terminated by c=s=0. Otherwise, both are positive, and, due to technical difficulties in the bracelet-fabrication-machine, cs<=32, i.e. their product does not exceed 32.
Output
For each test case output on a single line the number of unique bracelets. The figure below shows the 8 different bracelets that can be made with 2 colors and 5 beads.
Sample Input
1 1
2 1
2 2
5 1
2 5
2 6
6 2
0 0
Sample Output
1
2
3
5
8
13
21


分析:从题面能够看出是一个polya计数的题目,然后考虑从旋转和翻转两个方面的置换
 对于旋转:如果进行长度为i的旋转,那么最后循环节的总长度是lcm(i,n),也是n*i/__gcd(i,n),那么循环节包含的数的长度是 n/__gcd(i,n),n除以这个长度,即为循环节的个数__gcd(i,n);
对于翻转:如果n为奇数:那么对称轴一定过环的其中一点,共有n种置换,对于每种置换,循环节个数都是(n+1)/2
如果n为偶数:那么对称轴可能过环的两点,也可能不过环上的点,对于第一种情况,置换数为n/2,对于每种置换,循环节数为(n-2)/2+2,第二种情况置换数为n/2,对于每种置换,循环节数为n/2
代码如下:
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
typedef long long LL;
LL quick_mod(LL a,LL b)
{
   LL ans=1;
   while(b>0)
   {
      if(b&1) ans=ans*a;
      b>>=1;
      a=a*a;
   }
   return ans;
}
LL n,m,num;
int main()
{
    while(scanf("%lld%lld",&m,&n)!=EOF)
    {
        if(m==0&&n==0)break;
        num=0;
        for(LL i=1;i<=n;i++)
        num+=quick_mod(m,__gcd(i,n));
        if(n&1)num+=n*quick_mod(m,(n+1)/2);
        else num+=n/2*quick_mod(m,n/2+1)+n/2*quick_mod(m,n/2);
        num/=(n*2);
        cout<<num<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/a249189046/p/9794471.html