POJ 3250 Bad Hair Day (单调栈)

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input
Line 1: The number of cows, N.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.
Output
Line 1: A single integer that is the sum of c 1 through cN.
Sample Input
6
10
3
7
4
12
2
Sample Output
5

大致题意,给出牛的数量和每只牛的高度,对于每只牛,能看见右边比它矮的牛,直到被相同高度或更高的牛阻挡视野为止。
问所有的牛能够看到的总的牛数量之和

因为对于每头牛,我们需要找到右边第一个比它高的位置,所以可以用单调栈进行处理

#include<iostream>
#include<cstdio>
#include<cstring>
#include <stack>
using namespace std;
const int MAXN=8e4+10;
int a[MAXN];
int rr[MAXN];
int main()
{
   int n;
   long long ans;
   ios::sync_with_stdio(false);
   while(cin>>n)
   {
       ans=0;
       for(int i=1;i<=n;i++)
        cin>>a[i];

       stack<int>S;
       for(int i=1;i<=n;i++)
       {
           if(S.empty())
            S.push(i);
          else
          {
             while(!S.empty()&&a[S.top()]<=a[i])
             {
                rr[S.top()]=i-1;
                S.pop();
             }
             S.push(i);
          }
       }

       while(!S.empty())
       {
          rr[S.top()]=n;
          S.pop();
       }

       for(int i=1;i<=n;i++)
          ans+=rr[i]-i;
       cout<<ans<<endl;
   }
    return 0;
}



原文地址:https://www.cnblogs.com/a249189046/p/8724856.html