HDU 1010 Tempter of the Bone(DFS剪枝)

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 129289    Accepted Submission(s): 34906


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 
Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 
Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 
Sample Input
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 
Sample Output
NO YES
 
Author
ZHANG, Zheng
 
Source
 
Recommend
JGShining   |   We have carefully selected several similar problems for you:  1016 1241 1242 1072 1312 
 
分析:  需要剪枝的地方:一开始判断起点到终点的距离的奇偶,如果和时间的奇偶不相同就一定没有办法到
            然后DFS的时候每次判断当前至少需要的时间和剩下的时间进行比较
           找到合理方案后 结束DFS
代码如下:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
typedef long long ll;
char map1[35][35];
int dir[4][2]={1,0,-1,0,0,1,0,-1};
int vis[35][35];
int n,m,t,sx,sy,ex,ey,flag;
int check(int x,int y)
{
  if(x>=0&&x<n&&y>=0&&y<m&&!vis[x][y]&&map1[x][y]!='X')
  return 1;
  return 0;
}
void dfs(int x,int y,int step)
{
      if(flag==1)return;
   if(step>t)return;
  if(x==ex&&y==ey&&step==t)
  {
      flag=1;
      return;
  }
  for(int i=0;i<4;i++)
  {
      int nx=x+dir[i][0];
      int ny=y+dir[i][1];
    if(check(nx,ny))
    {
      vis[nx][ny]=1;
      dfs(nx,ny,step+1);
      vis[nx][ny]=0;
    }
  }
}
int main()
{
   while(scanf("%d%d%d",&n,&m,&t)!=EOF)
   {
       flag=0;
       if(n==0&&m==0&&t==0)break;
       for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
       {
          scanf(" %c",&map1[i][j]);
          if(map1[i][j]=='D')
          {
            ex=i;
            ey=j;
          }
          if(map1[i][j]=='S')
          {
            sx=i;
            sy=j;
          }
       }
       if(((abs(ex-sx)+abs(ey-sy))%2)!=(t%2))
        puts("NO");
       else
       {
          vis[sx][sy]=1;
           dfs(sx,sy,0);
           vis[sx][sy]=0;
           if(flag==1)
          puts("YES");
          else
            puts("NO");
       }
   }
    return 0;
}
原文地址:https://www.cnblogs.com/a249189046/p/7498746.html