[poj2528] Mayor's posters (线段树+离散化)

线段树 + 离散化


Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
Every candidate can place exactly one poster on the wall.
All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
The wall is divided into segments and the width of each segment is one byte.
Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.
此处输入图片的描述

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4


题目大意

在一面墙上,要贴上 n 张海报,给出海报的 l 和 r ,后贴上的海报会覆盖掉之前贴上的海报。问最后能看见几张海报。

很明显这是一道线段树的题。维护墙上每个点是哪张海报,区间修改,加懒惰标记。最后单点查询每个点是哪张海报。因为一张海报被分成的不同部分被看作是一张海报,所以用一个vis数组来标记是否出现过,如果没有则ans加一。
l 和 r 的区间范围是 (1e7) 如果直接开线段树可能会爆空间,所以需要离散化。

代码

#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
using namespace std;
#define ls u<<1, l, mid
#define rs u<<1|1,mid+1,r

const int maxn = 1e4 + 5;
int n,m;
int vis[maxn];
int nod[maxn << 4],add[maxn << 4];


struct qq {
	int l,r;
}q[maxn];

vector <int> v;
inline int getid(int x) {return lower_bound(v.begin(),v.end(),x) - v.begin() + 1;}

inline void pushdown(int u) {
	nod[u<<1] = nod[u<<1|1] = add[u];
	add[u<<1] = add[u<<1|1] = add[u];
	add[u] = 0;
}

void update(int u,int l,int r,int x,int y,int ad) {
	if(l == x && r == y) {
		nod[u] = ad;add[u] = ad;return;
	}
	if(add[u])pushdown(u);
	int mid = (l + r) >> 1;
	if(y <= mid) update(ls,x,y,ad);
	else if(x > mid) update(rs,x,y,ad);
	else {
		update(ls,x,mid,ad);update(rs,mid+1,y,ad);
	}
}

int query(int u,int l,int r,int x) {
	if(l == r)return nod[u];
	if(add[u])pushdown(u);
	int mid = (l + r) >> 1;
	if(x <= mid) return query(ls,x);
	return query(rs,x);
}

int main() {
	ios::sync_with_stdio(false); cin.tie(0);
	int t;cin >> t;
	while(t--) {
		cin >> n;
		for(int i = 1;i <= n;i++) {
			cin >> q[i].l >> q[i].r;
			v.push_back(q[i].l), v.push_back(q[i].r);
		}
		sort(v.begin(),v.end());v.erase(unique(v.begin(),v.end()),v.end());
		m = v.end() - v.begin();
		memset(nod,0,sizeof(nod));
		memset(add,0,sizeof(add));
		for(int i = 1;i <= n;i++) {
			update(1,1,m,getid(q[i].l),getid(q[i].r),i);
		}
		int ans = 0;
		memset(vis,0,sizeof(vis));
		for(int i = 1;i <= m;i++) {
			int x = query(1,1,m,i);
			if(x && !vis[x]) ans++,vis[x] = 1;
		}
		cout << ans << endl;
	}
	
	return 0;
} 
原文地址:https://www.cnblogs.com/ZegWe/p/5985629.html