pat 甲级 1038. Recover the Smallest Number (30)

1038. Recover the Smallest Number (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287

思路:可以先考虑其中任意两个字符串s1,s2,若s1+s2<s2+s1,那么s1必须要排在s2的左边才能使得最终结果尽可能的小,所以存在s1+s2>s2+s1的情况就对调s1,s2的位置,最终一定存在稳定状态,使得整个数字最小。这个模拟过程有点像冒泡排序
AC代码:
#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<set>
#include<queue>
#include<map>
using namespace std;
#define INF 0x3f3f3f
#define N_MAX 10000+5
typedef long long ll;
string s[N_MAX];
int n;
string process(string s) {
    int i = 0;
    while (i < s.size() && s[i] == '0')i++;
    string ss = s.substr(i, s.size() - i);
    if (!ss.size())ss = "0";
    return ss;
}
bool cmp(const string &s1,const string &s2) {
    return s1+s2 < s2+s1;
}
int main() {
    scanf("%d",&n);
    for (int i = 0; i < n; i++)cin >> s[i];
    sort(s, s + n, cmp);
    string S="";
    for (int i = 0; i < n;i++) {
        S+=s[i];
    }
    S = process(S);
    cout << S<<endl;
    return 0;
}
原文地址:https://www.cnblogs.com/ZefengYao/p/8577126.html