poj 3268 Silver Cow Party

                                                                                                   Silver Cow Party
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 19325   Accepted: 8825

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X 
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: AiBi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
 
思路:单元最短路径,dijkstra算法,出发时分别以每一个点作为起点,搜索到达终点的最短路径;以及回来时从终点到达各点的最短路径,最后将来回两条路径长度取和,取其中的最大值。
AC代码:
#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<functional>
using namespace std;
typedef pair<int, int> P;
const int V_MAX = 1000 + 16;
struct edge {
    int to, time;
};
int V;
vector<edge>G[V_MAX];
int d[V_MAX];
int x[V_MAX];
void dijkstra(int s) {
    priority_queue<P, vector<P>, greater<P>>que;
    fill(d,d+V,INT_MAX);
    d[s] = 0;
    que.push(P(0,s));
    while (!que.empty()) {
        P p = que.top();que.pop();
        int v = p.second;
        if (d[v] < p.first)continue;
        for (unsigned int i = 0;i < G[v].size();i++) {
            edge e = G[v][i];
            if (d[e.to] > d[v] + e.time) {
                d[e.to] = d[v] + e.time;
                que.push(P(d[e.to],e.to));
            }
        }
    }
}

int main() {
    int N, M,X;
    scanf("%d%d%d", &N, &M, &X);
           X--;
         V = N;
        for (int i = 0;i < M;i++) {
            edge E;
            int from;
            scanf("%d%d%d",&from,&E.to,&E.time);
            from--;E.to--;
            G[from].push_back(E);
        }
        dijkstra(X);
        memset(x,0,sizeof(x));
        for (int i = 0;i < V;i++) {
            x[i] += d[i];
        }
        for (int i = 0;i < V;i++) {
            dijkstra(i);//以i点为中心,
            x[i] += d[X];//计算i到目的地的最短距离并累加
        }
        int result = *max_element(x,x+V);
        printf("%d",result);
    return 0;
}

这样用dijkstra算法搜索次数过多,耗时过多,看了hankcs博主的文章,很有启发,思路:分别以目的地为起点和终点,使用两次dijkstra算法即可,这样一来存路径时需要用两个数组,一个存正向路径,一个存反向路径,正向路径用于计算以目的地为起点时走到各点的最短路径,反向路径用于计算以目的地为终点时各点走到目的地的最短路径。

AC代码:

#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<functional>
#include<string.h>
using namespace std;
typedef pair<int, int> P;
const int V_MAX = 1000 + 16;
struct edge {
    int to, time;
    edge() {};
    edge(int a,int b):to(a),time(b){}
};
int V;
vector<vector<edge>>G(V_MAX);//预定义容量,以防止越界
vector<vector<edge>>RG(V_MAX);
//vector<edge>G[V_MAX];
//vector<edge>RG[V_MAX];
int d[V_MAX];
int rd[V_MAX];
void dijkstra(int s) {
    priority_queue<P, vector<P>, greater<P>>que;
    fill(d,d+V,INT_MAX);
    d[s] = 0;
    que.push(P(0,s));
    while (!que.empty()) {
        P p = que.top();que.pop();
        int v = p.second;
        if (d[v] < p.first)continue;
        for (unsigned int i = 0;i < G[v].size();i++) {
            edge e = G[v][i];
            if (d[e.to] > d[v] + e.time) {
                d[e.to] = d[v] + e.time;
                que.push(P(d[e.to],e.to));
            }
        }
    }
}

int main() {
    int N, M,X;
    scanf("%d%d%d", &N, &M, &X);
           X--;
         V = N;
        for (int i = 0;i < M;i++) {
            edge E;
            int from,to,time;
            scanf("%d%d%d",&from ,&to,&time);
            from--;to--;
            G[from].push_back(edge(to,time));
            RG[to].push_back(edge(from,time));//存反向图
        }
        dijkstra(X);
        //G = RG;
        G.swap(RG);
        memcpy(rd,d,sizeof(d));
        dijkstra(X);
        for (int i = 0;i < V;i++) {
            d[i] += rd[i];
        }
        int result = *max_element(d,d+V);
        printf("%d",result);
    return 0;
}
原文地址:https://www.cnblogs.com/ZefengYao/p/5952936.html