poj 3046 Ant Counting

Ant Counting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4982   Accepted: 1896

Description

Bessie was poking around the ant hill one day watching the ants march to and fro while gathering food. She realized that many of the ants were siblings, indistinguishable from one another. She also realized the sometimes only one ant would go for food, sometimes a few, and sometimes all of them. This made for a large number of different sets of ants! 

Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1..T (A ants altogether). Each family had some number Ni (1 <= Ni <= 100) of ants. 

How many groups of sizes S, S+1, ..., B (1 <= S <= B <= A) can be formed? 

While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were: 

3 sets with 1 ant: {1} {2} {3} 
5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3} 
5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3} 
3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3} 
1 set with 5 ants: {1,1,2,2,3} 

Your job is to count the number of possible sets of ants given the data above. 

Input

* Line 1: 4 space-separated integers: T, A, S, and B 

* Lines 2..A+1: Each line contains a single integer that is an ant type present in the hive

Output

* Line 1: The number of sets of size S..B (inclusive) that can be created. A set like {1,2} is the same as the set {2,1} and should not be double-counted. Print only the LAST SIX DIGITS of this number, with no leading zeroes or spaces.

Sample Input

3 5 2 3
1
2
2
1
3

Sample Output

10

Hint

INPUT DETAILS: 

Three types of ants (1..3); 5 ants altogether. How many sets of size 2 or size 3 can be made? 


OUTPUT DETAILS: 

5 sets of ants with two members; 5 more sets of ants with three members
题意:有一个蚁巢,里面有T个不同的家族,每个家族有N_i只蚂蚁,共有A只蚂蚁,同家族蚂蚁无区分,从这A只蚂蚁中选取K只蚂蚁组成一个集合(S<=K<=B),问共能组成多少集合。
思路:定义dp[i][j]:从前i个家族取出j只蚂蚁的组合数。那么相当于考虑第i个家族若取出k(k<=min{family[i],j})只蚂蚁,前(i-1)个家族取出(j-k)只蚂蚁即可。
                min{family[i],j}
所以dp[i][j]=∑dp[i-1][j-k] 
                 k=0
节省空间考虑,可以用滚动数组。
AC代码:
#include<iostream>
#include<algorithm>
using namespace std;
const int MOD=1000000;
const int T_MAX=1000,A_MAX=10000;
int family[T_MAX];
int dp[2][A_MAX+1];
int main() {
    int T,A,S,B;
    while (cin >>T>> A>>S>>B) {
        memset(family, 0, sizeof(family));
        for (int i = 0;i < A;i++) {
            int index;
            cin >> index;
            family[index]++;
        }
        int total = 0;
        dp[0][0] = 1;//从0个家族取出0只蚂蚁,只有一种可能
        for (int i = 1;i <= T;i++) {
            total += family[i];
            int cur =i&1 ;
            int pre = (i - 1) & 1;
            memset(dp[cur],0,sizeof(dp[cur]));//清除上次记录
            for (int k = 0;k <= family[i];k++) {
                for (int j = total;j >= k;j--) {//这j只蚂蚁总数不能超过这几个家族蚂蚁的总数
                    dp[cur][j] =(dp[cur][j]+ dp[pre][j - k])%MOD;
                }
            }
        }
        int cur = T&1;
        int result=0;
        for (int i = S;i <= B;i++) {
            result =(result+ dp[cur][i])%MOD;
        }
        cout << result << endl;
        memset(dp[(T - 1) & 1], 0, sizeof(dp[(T - 1) & 1]));
    }
    return 0;
}
 
 
原文地址:https://www.cnblogs.com/ZefengYao/p/5875000.html