poj 3262 Protecting the Flowers

Protecting the Flowers
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 6484   Accepted: 2595

Description

Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.

Each cow i is at a location that is Ti minutes (1 ≤ Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroys Di (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cow i to its barn requires 2 × Ti minutes (Ti to get there and Ti to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.

Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

Input

Line 1: A single integer N 
Lines 2..N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow's characteristics

Output

Line 1: A single integer that is the minimum number of destroyed flowers

Sample Input

6
3 1
2 5
2 3
3 2
4 1
1 6

Sample Output

86

Hint

FJ returns the cows in the following order: 6, 2, 3, 4, 1, 5. While he is transporting cow 6 to the barn, the others destroy 24 flowers; next he will take cow 2, losing 28 more of his beautiful flora. For the cows 3, 4, 1 he loses 16, 12, and 6 flowers respectively. When he picks cow 5 there are no more cows damaging the flowers, so the loss for that cow is zero. The total flowers lost this way is 24 + 28 + 16 + 12 + 6 = 86.
 
题意:一群牛在花园一个地方吃花,约翰要把牛一头一头牵回栅栏,每头牛牵回栅栏时间不同,且每分钟都会吃不同数量的花,约翰应该按照什么顺序牵牛,使得被吃掉的花数量最少。
思路:设每头牛牵回栅栏的时间为T_i,每分钟吃花数为D_i,每头牛按照(D_i/T_i)从大到小的顺序牵,存放入最大堆即可。
AC代码:
#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
const int N_MAX = 100000;
struct cow {
    float T;//每头牛往返半程时间
    float D;//每头牛每分钟吃花数量
    bool operator <(const cow&b)const {
        return (D / T) < (b.D / b.T);
    }
};
cow cows;
priority_queue<cow>que;
int main() {
    int N;
    while (cin >> N) {
        long long sum = 0;
        for (int i = 0;i < N;i++) {
            scanf("%f%f", &cows.T, &cows.D);
            sum += cows.D;
            que.push(cows);
        }
        
        long long flower=0;
        for (int i = 0;i < N-1;i++) {
            sum -= que.top().D;
            flower += 2*que.top().T*sum;
            que.pop();
        }
        que.pop();
        cout << flower << endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/ZefengYao/p/5836851.html