BZ2763: [JLOI2011]飞行路线

Description

Alice和Bob现在要乘飞机旅行,他们选择了一家相对便宜的航空公司。该航空公司一共在n个城市设有业务,设这些城市分别标记为0到n-1,一共有m种航线,每种航线连接两个城市,并且航线有一定的价格。Alice和Bob现在要从一个城市沿着航线到达另一个城市,途中可以进行转机。航空公司对他们这次旅行也推出优惠,他们可以免费在最多k种航线上搭乘飞机。那么Alice和Bob这次出行最少花费多少?

Input

数据的第一行有三个整数,n,m,k,分别表示城市数,航线数和免费乘坐次数。

第二行有两个整数,s,t,分别表示他们出行的起点城市编号和终点城市编号。(0<=s,t<n)

接下来有m行,每行三个整数,a,b,c,表示存在一种航线,能从城市a到达城市b,或从城市b到达城市a,价格为c。(0<=a,b<n,a与b不相等,0<=c<=1000)

Output

只有一行,包含一个整数,为最少花费。

Sample Input

5 6 1
0 4
0 1 5
1 2 5
2 3 5
3 4 5
2 3 3
0 2 100

Sample Output

8

HINT

对于30%的数据,2<=n<=50,1<=m<=300,k=0;

对于50%的数据,2<=n<=600,1<=m<=6000,0<=k<=1;

对于100%的数据,2<=n<=10000,1<=m<=50000,0<=k<=10.


分层图模板,裸到都不用建分层图的那种==
把状态加一维(a[i][k])表示到达(i)时经过过(k)条0边的最短路径长度,然后在原图上跑最短路就行了


#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define MP make_pair
#define S second
#define F first
using namespace std;

int i,m,n,j,k,a[100001][25],x,y,z,ver[100011],nex[100010],head[100010],cnt,edge[100010],ans=0x3f3f3f3f,s,v;
bool b[100001][25];
priority_queue <pair<int,pair<int,int> > > q;
void add(int x,int y,int z)
{
	cnt+=1;
	ver[cnt]=y; nex[cnt]=head[x]; head[x]=cnt; edge[cnt]=z;
	cnt+=1;
	ver[cnt]=x; nex[cnt]=head[y]; head[y]=cnt; edge[cnt]=z;
}

void dji()
{
	a[s][0]=0;
	q.push(MP(0,MP(s,0)));
	while(q.size())
	{
		while(q.size() && b[q.top().S.F][q.top().S.S]) q.pop();
		if(!q.size()) break;
		int g=q.top().S.F, h=q.top().S.S;
		b[g][h]=1;
		for(int i=head[g];i;i=nex[i])
		{
			int t=ver[i];
			if(h!=k) if(a[t][h+1]>a[g][h]) a[t][h+1]=a[g][h], q.push(MP(-a[t][h+1],MP(t,h+1)));
			if(a[t][h]>a[g][h]+edge[i]) a[t][h]=a[g][h]+edge[i], q.push(MP(-a[t][h],MP(t,h)));
		}
	}
}

int main()
{
	scanf("%d%d%d",&n,&m,&k);
	scanf("%d%d",&s,&v);
	memset(a,0x3f,sizeof(a));
	for(i=1;i<=m;i++) 
	{
		scanf("%d%d%d",&x,&y,&z);
		add(x,y,z);
	}
	dji();
	for(i=0;i<=k;i++) ans=min(ans,a[v][k]);
	printf("%d",ans);
}
原文地址:https://www.cnblogs.com/ZUTTER/p/9615185.html