P3147 [USACO16OPEN]262144

题目描述

Bessie likes downloading games to play on her cell phone, even though she doesfind the small touch screen rather cumbersome to use with her large hooves.

She is particularly intrigued by the current game she is playing.The game starts with a sequence of N positive integers ( (2≤N≤262,144) ), each in the range (1…40). In one move, Bessiecan take two adjacent numbers with equal values and replace them asingle number of value one greater (e.g., she might replace twoadjacent 7s with an 8). The goal is to maximize the value of thelargest number present in the sequence at the end of the game. Pleasehelp Bessie score as highly as possible!

Bessie喜欢在手机上下游戏玩(……),然而她蹄子太大,很难在小小的手机屏幕上面操作。

她被她最近玩的一款游戏迷住了,游戏一开始有n个正整数,(2<=n<=262144),范围在1-40。在一步中,贝西可以选相邻的两个相同的数,然后合并成一个比原来的大一的数(例如两个7合并成一个8),目标是使得最大的数最大,请帮助Bessie来求最大值。

输入输出格式

输入格式:

The first line of input contains N, and the next N lines give the sequence

of N numbers at the start of the game.

输出格式:

Please output the largest integer Bessie can generate.

输入输出样例

输入样例#1: 复制

4
1
1
1
2

输出样例#1: 复制

3

说明

In this example shown here, Bessie first merges the second and third 1s to

obtain the sequence 1 2 2, and then she merges the 2s into a 3. Note that it is

not optimal to join the first two 1s.


简化版:

Bessie likes downloading games to play on her cell phone, even though she doesfind the small touch screen rather cumbersome to use with her large hooves.

She is particularly intrigued by the current game she is playing.The game starts with a sequence of (N)positive integers ( (2≤N≤248) ), each in the range (1…40) . In one move, Bessie cantake two adjacent numbers with equal values and replace them a singlenumber of value one greater (e.g., she might replace two adjacent 7swith an 8). The goal is to maximize the value of the largest numberpresent in the sequence at the end of the game. Please help Bessiescore as highly as possible!


看着这么小的数据范围,有点不知所措,(f[i][j])表示(i -j)这段区间能凑成的最大数字
穷举(k,i,j)时转移方程(f[i][j]=max(f[i][j],(f[i][k]==f[k+1][j]) | f[i][k]+1))

#include<iostream>
#include<stdio.h>

using namespace std;

int i,m,n,j,k,maxx,a[1000001],f[300][300];

int main()
{
    scanf("%d",&n);
    for(i=1;i<=n;i++) scanf("%d",&f[i][i]);
    for(i=n-1;i>=1;i--)
        for(j=i;j<=n;j++)
            for(k=j+1;k<=n;k++)
            {
                if(f[i][j]==f[j+1][k]) f[i][k]=max(f[i][k],f[i][j]+1);
                if(f[i][k]>maxx) maxx=f[i][k];
            }
    printf("%d",maxx);
}

这道题(n≤262144) , (x≤40) 告诉我们要找一个(n cdot x)的算法就很明显了嘛
(f[i][k][b])(b=1)时表示第(i) 个位置是否是一个能够拼出值(k)的右端点,如果是,(f[i][k][b]) 存的是左端点的位置。(b=0)时则相反

由于右端点为(x)区间权值为(k)的区间是确定的,所以只要每次枚举每个断点即可

#include<iostream>
#include<cstdio>

using namespace std;

int i,m,n,j,k,a[262166][60][2],b[262166],ans;

int main()
{
	scanf("%d",&n);
	for(i=1;i<=n;i++) scanf("%d",&b[i]),a[i][b[i]][1]=a[i][b[i]][0]=i;
	for(i=1;i<=60;i++)
		for(j=1;j<n;j++)
		{
			if(a[j][i][0] && a[j+1][i][1]) 
			{
				a[a[j][i][0]][i+1][1]=a[j+1][i][1];
				a[a[j+1][i][1]][i+1][0]=a[j][i][0];
				ans=i+1;
			}
		}
	printf("%d",ans);
}
原文地址:https://www.cnblogs.com/ZUTTER/p/9468292.html