Air Raid

Description

Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town’s streets you can never reach the same intersection i.e. the town’s streets form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.
Input

Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2

Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town’s streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.
Output

The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.
Sample Input

2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3
Sample Output

2
1

.
.
.
.
.
分析
在这里插入图片描述
由原图G构造对应的二分图S,将原图G中的每个点i拆成两个点i1和i2,i1和i2属于S。i1组成二分图的X集合,i2组成Y集合。若原图G中有边<i,j>,则在S中有边<i1,j2>,则上面的图可以得到如下二分图:

在这里插入图片描述
方法:把原图的每个点V拆成Vx和Vy两个点,
如果有一条有向边A->B,那么就加边Ax−>By
。这样就得到了一个二分图。
那么最小路径覆盖=原图的结点数-新图的最大匹配数。

.
.
.
.
.
程序:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int ans,tj,n,m,link[4000],v[4000],head[4000];

struct node
{
	int to,next;
}f[4000];

int find(int x)
{
	for (int i=head[x];i;i=f[i].next)
	{
		int j=f[i].to;
		if (!v[j])
		{
			int q=link[j];
		    link[j]=x;
		    v[j]=1;
		    if (!q||find(q)) return 1;
		    link[j]=q;
		}
		
	}
	return 0;
}

int main()
{
	int t;
	scanf("%d",&t);
	for (int u=1;u<=t;u++)
	{
		memset(f,0,sizeof(f));
		memset(head,0,sizeof(head));
		memset(link,0,sizeof(link));
		scanf("%d",&n);
		scanf("%d",&m);
		tj=0;
		for (int i=1;i<=m;i++)
		{
			int x,y;
			scanf("%d%d",&x,&y);
		
			f[++tj].next=head[x];
			f[tj].to=y;
			head[x]=tj;
		}
		ans=0;
		for (int i=1;i<=n;i++)
		{
			memset(v,0,sizeof(v));
			ans+=find(i);
		}
		cout<<n-ans<<endl;
	}
	return 0;
}
原文地址:https://www.cnblogs.com/YYC-0304/p/10292798.html