Max Sum -- hdu -- 1003

链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1003

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 180817    Accepted Submission(s): 42261


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 
Sample Output
Case 1: 14 1 4
Case 2: 7 1 6


5 6 -1 5 4 -7
6 5 10 14 7  
Case 1:
14 1 4

7 0 6 -1 1 -6 7 -5
0 6 5 6 0 7 2
Case 2:
7 1 6

 

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <queue>

using namespace std;

#define N 110000
#define INF 0xffffff

int sum[N];

int main()
{

    int t, iCase=1;
    scanf("%d", &t);

    while(t--)
    {
        int i, n, Max=-INF, Min=INF, a, L, Left, Right;

        scanf("%d", &n);

        for(i=1; i<=n; i++)
        {
            scanf("%d", &a);
            sum[i] = sum[i-1]+a;
        }
/// Left = Right = 1;
        for(i=1; i<=n; i++)
        {
///找出最小的sum[i]
if(sum[i-1]<Min) { Min = sum[i-1]; L = i; } ///找出最大的Max if(sum[i]-Min>Max) { Max = sum[i]-Min; Left = L; Right = i; } } printf("Case %d: ", iCase++); printf("%d %d %d ", Max, Left, Right); if(t) printf(" "); } return 0; }
勿忘初心
原文地址:https://www.cnblogs.com/YY56/p/4779905.html