POJ3624 Charm Bracelet[01背包问题入门]

Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12564   Accepted: 5745

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

 
 
 
自己做的一道01背包入门题,比较简单。
code:
#include<iostream>
#include<stdio.h> 
using namespace std;
int main()
{
	int n,m;
	int i,j;
	int w[3403],d[3403];
	int dp[12881]; 
	while(~scanf("%d%d",&n,&m))
	{
		memset(dp,0,sizeof(dp));
		for(i=0;i<n;i++)
		    scanf("%d%d",&w[i],&d[i]);
        for(i=0;i<n;i++)
            for(j=m;j>=w[i];j--)
                if(dp[j-w[i]]+d[i]>dp[j])
                    dp[j]=dp[j-w[i]]+d[i];
        printf("%d\n",dp[m]);
	}
	return 0;
}

POJ写代码要加上C的头文件,或是用C++提交,不然会出现CE。







            If you have any questions about this article, welcome to leave a message on the message board.



Brad(Bowen) Xu
E-Mail : maxxbw1992@gmail.com


原文地址:https://www.cnblogs.com/XBWer/p/2598662.html