Intervals

Intervals
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 8271   Accepted: 3268

Description

There is given the series of n closed intervals [ai; bi], where i=1,2,...,n. The sum of those intervals may be represented as a sum of closed pairwise non−intersecting intervals. The task is to find such representation with the minimal number of intervals. The intervals of this representation should be written in the output file in acceding order. We say that the intervals [a; b] and [c; d] are in ascending order if, and only if a <= b < c <= d. 
Task 
Write a program which: 
reads from the std input the description of the series of intervals, 
computes pairwise non−intersecting intervals satisfying the conditions given above, 
writes the computed intervals in ascending order into std output

Input

In the first line of input there is one integer n, 3 <= n <= 50000. This is the number of intervals. In the (i+1)−st line, 1 <= i <= n, there is a description of the interval [ai; bi] in the form of two integers ai and bi separated by a single space, which are respectively the beginning and the end of the interval,1 <= ai <= bi <= 1000000.

Output

The output should contain descriptions of all computed pairwise non−intersecting intervals. In each line should be written a description of one interval. It should be composed of two integers, separated by a single space, the beginning and the end of the interval respectively. The intervals should be written into the output in ascending order.

Sample Input

5
5 6
1 4
10 10
6 9
8 10

Sample Output

1 4
5 10


大概是让区间合并,输出合并后的所有区间。
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
struct node
{
    int h,t;
}a[100000];
bool cmpp(node a,node b)
{
     return a.h<b.h;
}
int main()
{
    int n,i,j;
    cin>>n;
    for(i=0;i<n;i++)
        cin>>a[i].h>>a[i].t;
    sort(a,a+n,cmpp);//区间排序
    int x=a[0].h,y=a[0].t;
    for(i=1;i<n;i++)
    {
        if(a[i].h>y)//合并条件
        {
            cout<<x<<" "<<y<<endl;
            x=a[i].h;
            y=a[i].t;
        }
        else
            y=max(y,a[i].t);
    }
    cout<<x<<" "<<y;
    return 0;
}

  

蒟蒻总是更懂你✿✿ヽ(°▽°)ノ✿
原文地址:https://www.cnblogs.com/WWHHTT/p/6922650.html