PAT 1007——Maximum Subsequence Sum

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

解法就是计算到数组中各个数为止的最大和,如果小于0就重新开始计算。忘了这个想法的来源是哪里了,可能是动态规划里的LIS?
注意一下0的情况。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cctype>
#include <cstdlib>
#include<cmath>
#include <string>
#include <map>
#include <set>
#include <queue>
#include <vector>
#include <stack>
#include <cctype>
using namespace std;
typedef unsigned long long ull;
#define INF 0xfffffff


int main()
{ 
    int x,y,n,m,i,j,k,ans;

    int a[10000];
    m=0;
    while(cin>>n)
    {
        for(i=0;i<n;++i)
        {
            cin>>a[i];
            if(a[i]>=0)
            {
                m=1;
            }
        }
        if(!m)
        {
            printf("%d %d %d",0,a[0],a[n-1]);
            continue;
        }
        i=j=k=0;
        m=-1;
        for(;j<n;++j)
        {
            k+=a[j];
            if(k<0)
            {
                k=0;
                i=j+1;
            }
            else if(k>m)
            {
                x=a[i];y=a[j];m=k;
            }
        }        
        printf("%d %d %d",m,x,y);
    }
    
  
  return 0;
}
原文地址:https://www.cnblogs.com/Traveller-Leon/p/5020239.html