HDU--2053

Switch Game

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12748    Accepted Submission(s): 7753


Problem Description
There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).
 

Input
Each test case contains only a number n ( 0< n<= 10^5) in a line.
 

Output
Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).
 

Sample Input
1 5
 

Sample Output
1 0
Hint
hint
Consider the second test case: The initial condition : 0 0 0 0 0 … After the first operation : 1 1 1 1 1 … After the second operation : 1 0 1 0 1 … After the third operation : 1 0 0 0 1 … After the fourth operation : 1 0 0 1 1 … After the fifth operation : 1 0 0 1 0 … The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.
 

Author
LL

#include <iostream>
using namespace std;

int main()
{
	int n;
	while (cin >> n)
	{
		int num=0; 
		for (int i=1; i<=n; i++)
		{
			if (n %i ==0)
				num++;
		}
		if (num%2 == 0)
			cout << 0;
		else
			cout << 1;
		cout <<endl;
	}
	return 0;
}

该题实际上就是一个求数因子个数的题目,刚开始我的第一思路就是打算用数组去保留每次的结果,但是很明显会超时。并且非常复杂,再仔细看看题目,看到了无限次,发现经过几次操作之后前面的一些数的结果不会改变了,然后仔细一想这就是一个求因子的!!
原文地址:https://www.cnblogs.com/Tovi/p/6194898.html