HDU_5523Game

Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 159    Accepted Submission(s): 74


Problem Description
XY is playing a game:there are N pillar in a row,which numbered from 1 to n.Each pillar has a jewel.Now XY is standing on the S-th pillar and the exit is in the T-th pillar.XY can leave from the exit only after they get all the jewels.Each time XY can move to adjacent pillar,or he can jump to boundary ( the first pillar or the N-th pillar) by using his superpower.However,he needs to follow a rule:if he left the pillar,he no can not get here anymore.In order to save his power,XY wants to use the minimum number of superpower to pass the game.
 

Input
There are multiple test cases, no more than 1000 cases.
For each case,the line contains three integers:N,S and T.(1N10000,1S,TN)
 

Output
The output of each case will be a single integer on a line: the minimum number of using superpower or output -1 if he can't leave.
 

Sample Input
4 1 4 4 1 3
 

Sample Output
0 1
无解的情况只有起点和终点位置一样且N不为1。终点和起点都在边界上答案为0,如果起点在边界上或者起点终点相邻答案为1,其他答案为2.
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
#include <string>
#include <cmath>
using namespace std;

int main() {
	int n, s, t;
	while (cin >> n>>s >> t) {
		if (n == 1)
			cout << 0<< endl;
		else {
			if (s == t)
				cout << -1<< endl;
			else if ((s == 1 && t == n) || (s == n && t == 1))
				cout << 0<< endl;
			else if ((s == 1 || s == n) || abs(s-t) == 1)
				cout << 1<< endl;
			else
				cout << 2<< endl;
		}
	}
	return 0;
}


原文地址:https://www.cnblogs.com/Tovi/p/6194836.html