Problem D: 整型数组运算符重载

Description

定义Array类:

1.拥有数据成员int length和int *mems,分别是数组中元素的个数和元素列表。

2. 无参构造函数,将mems设置为NULL,length为0。

3. 重载==运算符,用于判断两个Array对象是否相等。相等包括两种情况:(1)两个对象是同一个对象,即它们拥有相同的地址(记住: this指针指向当前对象,是当前对象的地址);(2)两个对象的length相同,且mems中对应元素的值相同。其他情况均为不相等。

4. 利用友元函数重载<<和>>运算符。输入、输出格式见下。

Input

输入分多行。

第一行是一个正整数M,表示有M个数组。

每个数组是一行,其中第一个非负整数N表示该数组的元素个数,之后有N个整数。

Output

输出有M行。

第一行输出即为第一个数组。

自第二行开始,首先输出对应的数组元素(两两之间用空格隔开,首尾不能有空格),如果数组为空,则不输出元素。之后根据这个数组与上个数组是否相同,输出“unequal to above.”(不相等)和“equal to above”(相等)。

Sample Input

5 3 1 2 3 3 1 2 3 0 7 1 2 3 4 5 6 7 7 1 2 3 4 5 6 8

Sample Output

1 2 3 1 2 3 equal to above. unequal to above. 1 2 3 4 5 6 7 unequal to above. 1 2 3 4 5 6 8 unequal to above.

HINT

Append Code

#include<iostream>
using namespace std;
class Array
{
private:
    int length;
    int *mems;
public:
    Array(){length=0;mems=NULL;}
    ~Array(){if(mems!=NULL)delete []mems;}
    int operator == (Array &a)
    {
        if(this==&a)
            return 1;
         else   if(length==a.length)
        {
            for(int i=0;i<length;i++)
            {
                if(mems[i]!=a.mems[i])
                {
                    return 0;//贾玲
                }
            }
            return 1;
        }
        else
            return 0;
    }
    friend ostream &operator<<(ostream &os,const Array &a)
    {
        for(int i=0;i<a.length;i++)
        if(i==0)
            os<<a.mems[i];
        else
            os<<" "<<a.mems[i];
        return os;
    }
    friend istream &operator>>(istream &is,Array &a)
    {
        is>>a.length;//直接入
        if(a.mems!=NULL)
            delete []a.mems;//彬神,勿忘释放
        a.mems=new int [a.length];//申请
        for(int i=0;i<a.length;i++)
            is>>a.mems[i];
        return is;
    }
};
int main()
{
    int cases;
    cin>>cases;
    Array arraies[cases];
    for (int i = 0; i < cases; i++)
    {
        cin>>arraies[i];
    }
    cout<<arraies[0]<<endl;
    for (int i = 1; i < cases; i++)
    {
        if (arraies[i] == arraies[i - 1])
        {
            cout<<arraies[i]<<" "<<"equal to above."<<endl;
        }
        else
        {
            cout<<arraies[i]<<" "<<"unequal to above."<<endl;
        }
    }
    return 0;
}


原文地址:https://www.cnblogs.com/TogetherLaugh/p/6623472.html