pat 1048. Find Coins (25)

1048. Find Coins (25)

时间限制
50 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.

Sample Input 1:
8 15
1 2 8 7 2 4 11 15
Sample Output 1:
4 11
Sample Input 2:
7 14
1 8 7 2 4 11 15
Sample Output 2:
No Solution
解:排序+折半查找法

#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
int a[100000+1];
int search(int hhd,int left,int right)  //折半查找法
{
    while(left<=right)
    {
        int mid=(left+right)/2;
        if(hhd<a[mid])
        {
            right=mid-1;
        }
        else if(hhd>a[mid])
        {
            left=mid+1;
        }
        else if(hhd==a[mid])
        {
            return 1;
        }
    }
    return 0;
}
int main()
{
   int n,m;
   while(cin>>n>>m)
   {
       for(int i=0;i<n;i++)
       {
           cin>>a[i];
       }
       sort(a,a+n);
       int flag=0;
       for(int i=0;i<n;i++)
       {
           if(search(m-a[i],i+1,n-1)==1)
           {
               cout<<a[i]<<' '<<m-a[i]<<endl;
               flag=1;
               break;
           }
       }
       if(flag==0)
          cout<<"No Solution"<<endl;
   }
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

原文地址:https://www.cnblogs.com/Tobyuyu/p/4965295.html