HDU 2001 计算两点间的距离

题目链接:HDU 2001

Description

输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。

Input

输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。

Output

对于每组输入数据,输出一行,结果保留两位小数。

Sample Input

0 0 0 1
0 1 1 0

Sample Output

1.00
1.41

代码

import java.util.*;
class Main{
	public static void main(String []args){
		Scanner read=new Scanner(System.in);
		double x1,x2,y1,y2;
		while(read.hasNextDouble()){
			x1=read.nextDouble();
			y1=read.nextDouble();
			x2=read.nextDouble();
			y2=read.nextDouble();
			//double  s=read.nextDouble();
		System.out.println(String.format("%.2f",Math.sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2))));}
	}
}
原文地址:https://www.cnblogs.com/Titordong/p/9665734.html