Find The Multiple

 Find The Multiple
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

其实一开始我是没读懂题意的,可爱善良的伙伴给我说的:找到任意一由0,1组成的十进制数,满足是n的倍数,输出就行。
怎么做呢,还是while,queue。
#include<iostream>
#include<queue>

using namespace std;

int n;

long long bfs(long long sum)
{
    queue <long long> Q;  // 定义队列

    Q.push(1); // 把1进队

    while(1)
    {
        long long q = Q.front();   // 取数

        if(q % n == 0)
            return q;   // 满足题意结束函数,返回满足题意要求数

        Q.pop();
        Q.push(q*10); // 不满足,继续找下一个0,1数,进队
        Q.push(q*10+1); // 10,11.,100,101,110,111
    }
}
int main()
{
    while(cin >> n, n)
    {
        cout << bfs(1) << endl;  // 0,1数字最小是1,so,从1开始
    }
    return 0;
}
让未来到来 让过去过去
原文地址:https://www.cnblogs.com/Tinamei/p/4653805.html