[解题报告]HDU 1720 A+B Coming

A+B Coming

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4331    Accepted Submission(s): 2771


Problem Description
Many classmates said to me that A+B is must needs.
If you can’t AC this problem, you would invite me for night meal. ^_^
 
Input
Input may contain multiple test cases. Each case contains A and B in one line.
A, B are hexadecimal number.
Input terminates by EOF.
 
Output
Output A+B in decimal number in one line.
 
Sample Input
1 9 A B a b
 
Sample Output
10 21 21
 
Author
威士忌
 
Source
 
Recommend
lcy
 

如果你首先想到的是转成十进制再加那你就弱爆了

#include<stdio.h>
int main()
{
     int i,j,sum;
     while(scanf("%x%x",&i,&j)!=EOF)
     {
        sum=i+j;
        printf("%d\n",sum);
     }
     return 0;
}
原文地址:https://www.cnblogs.com/TheLaughingMan/p/3104262.html