[解题报告]HDU 1092 A+B for InputOutput Practice (IV)

A+B for Input-Output Practice (IV)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 46866    Accepted Submission(s): 24976


Problem Description
Your task is to Calculate the sum of some integers.
 
Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
 
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
 
Sample Input
4 1 2 3 4 5 1 2 3 4 5 0
 
Sample Output
10 15
 
Author
lcy
 
Recommend
JGShining
 
 
 
 
一般来说都会想到用数组做吧,但是考虑到空间复杂度还是这样做比较好
 
#include<stdio.h>
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n)
    {
        int sum=0;
        while(n--)
    {
        int a;
        scanf("%d",&a);
        sum+=a;
    }
    printf("%d\n",sum);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/TheLaughingMan/p/2983163.html