[解题报告]10107 What is the Median?

What is the Median? 

The Problem

Median plays an important role in the world of statistics. By definition, it is a value which divides an array into two equal parts. In this problem you are to determine the current median of some long integers.

Suppose, we have five numbers {1,3,6,2,7}. In this case, 3 is the median as it has exactly two numbers on its each side. {1,2} and {6,7}.

If there are even number of values like {1,3,6,2,7,8}, only one value cannot split this array into equal two parts, so we consider the average of the middle values {3,6}. Thus, the median will be (3+6)/2 = 4.5. In this problem, you have to print only the integer part, not the fractional. As a result, according to this problem, the median will be 4!

Input 

The input file consists of series of integers X ( 0 <= X < 2^31 ) and total number of integers N is less than 10000. The numbers may have leading or trailing spaces.

Output 

For each input print the current value of the median.

Sample Input 

1
3
4
60
70
50
2

Sample Output 

1
2
3
3
4
27
4

Sadi Khan
2001-04-01

关键句:For each input print the current value of the median.

略水

#include<stdio.h>
int main()
{
  int N[10005],top=0,temp;
  int i,j;
  while(scanf("%d",&N[top++])!=EOF)
  {
    for(i=0;i<top;i++)
      if(N[top-1]> N[i])
      {
        temp=N[top-1];
        for(j=top-1;j>i;j--) N[j]=N[j-1];
        N[i]=temp;
        break;
      }
    if(top%2)
      printf("%d\n",N[top/2]);
    else
      printf("%d\n",(N[top/2]+N[top/2-1])/2);
  }
  return 0;
}
原文地址:https://www.cnblogs.com/TheLaughingMan/p/2924735.html