[解题报告]264 Count on Cantor

 Count on Cantor 

One of the famous proofs of modern mathematics is Georg Cantor's demonstration that the set of rational numbers is enumerable. The proof works by using an explicit enumeration of rational numbers as shown in the diagram below.

displaymath27

In the above diagram, the first term is 1/1, the second term is 1/2, the third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so on.

Input and Output

You are to write a program that will read a list of numbers in the range from 1 to tex2html_wrap_inline29 and will print for each number the corresponding term in Cantor's enumeration as given below. No blank line should appear after the last number.

The input list contains a single number per line and will be terminated by end-of-file.

Sample input

3
14
7

Sample output

TERM 3 IS 2/1
TERM 14 IS 2/4
TERM 7 IS 1/4




先锁定N在那个斜行,在根据所在斜行第一个数的编号和下一斜行的第一个编号确定
#include<stdio.h>
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int i=1,j=0;
        int k,temp1,temp2,temp3;
        for(k=1;;k++)
   {
       j=i+k;
       if(n>=i&&n<j)
       {
           temp1=k;//所在斜行
           temp2=i;//所在斜行第一个数
           temp3=j;//所在斜行下一行第一个数
           break;
       }
       i=j;
   }
        if(temp1%2==0) printf("TERM %d IS %d/%d\n",n,n-temp2+1,temp1+1-(n-temp2+1));
        else printf("TERM %d IS %d/%d\n",n,temp3-n,temp1+1-(temp3-n));
    }
    return 0;
}
原文地址:https://www.cnblogs.com/TheLaughingMan/p/2923072.html