[解题报告]151 Power Crisis

 Power Crisis 

During the power crisis in New Zealand this winter (caused by a shortage of rain and hence low levels in the hydro dams), a contingency scheme was developed to turn off the power to areas of the country in a systematic, totally fair, manner. The country was divided up into N regions (Auckland was region number 1, and Wellington number 13). A number, m, would be picked `at random', and the power would first be turned off in region 1 (clearly the fairest starting point) and then in every m'th region after that, wrapping around to 1 after N, and ignoring regions already turned off. For example, if N = 17 and m = 5, power would be turned off to the regions in the order:1,6,11,16,5,12,2,9,17,10,4,15,14,3,8,13,7.

The problem is that it is clearly fairest to turn off Wellington last (after all, that is where the Electricity headquarters are), so for a given N, the `random' number m needs to be carefully chosen so that region 13 is the last region selected.

Write a program that will read in the number of regions and then determine the smallest number m that will ensure that Wellington (region 13) can function while the rest of the country is blacked out.

Input and Output

Input will consist of a series of lines, each line containing the number of regions (N) with tex2html_wrap_inline42 . The file will be terminated by a line consisting of a single 0.

Output will consist of a series of lines, one for each line of the input. Each line will consist of the number m according to the above scheme.

Sample input

17
0

Sample output

7





首先处理一下方便解题
先把头一个先去掉,再从0开始编号,
这样就不是13号留最后,而是11留最后。
不折返顺着m个m个的关,把同一趟最后关的下一个当做第一个,开头的接在这一趟的最后,已经关闭的当做删除
这样只要保证某一次的第一个是11然后输出m就可以了
#include<stdio.h>
int main()
{
  int N,m,t;
  int i;
  while(scanf("%d",&N)!=EOF&&N!=0)
  {
    for(m=1;m<N-1;m++)
    {
      t=0;
      for(i=1;i<N;i++) 
        t=(t+m)%i;
      if(t==11) break;
    }
    printf("%d\n",m);
  }
  return 0;
}
原文地址:https://www.cnblogs.com/TheLaughingMan/p/2923037.html