[解题报告]10038 Jolly Jumpers

Problem E: Jolly Jumpers

A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance,

1 4 2 3

is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.

Input

Each line of input contains an integer n <= 3000 followed by n integers representing the sequence.

Output

For each line of input, generate a line of output saying "Jolly" or "Not jolly".

Sample Input

4 1 4 2 3
5 1 4 2 -1 6

Sample Output

Jolly
Not jolly




发现很多和绝对值有关的题目都没有用abs函数啊。。。。

#include<stdio.h>
void main()
{
    int t,n,a,b,x,i;
    while(scanf("%d",&t)!=EOF)
    {
        int s[3000]={0};
        n=0;
        scanf("%d",&a);           //输入共有几个数
        for(i=1;i<t;i++)
        {
            scanf("%d",&b);       //逐个扫描
            x=a>b?a-b:b-a;        //记录差值 
            s[x]=1;               //把差值作为下标
            a=b;                  //每次往后挪一个两两比较
        }
        for(i=1;i<=t-1;i++)
            if(!s[i])             //如果数组不连续为1,则不匹配
            {
                n=1;
                break;
            }
    if(n)
        printf("Not jolly\n");
    else
        printf("Jolly\n");
    }
}
原文地址:https://www.cnblogs.com/TheLaughingMan/p/2908256.html