Doki Doki Literature Club ZOJ

https://vjudge.net/problem/ZOJ-4035/origin

https://vjudge.net/contest/399385#problem/L

Doki Doki Literature Club! is a visual novel developed by Team Salvato. The protagonist is invited by his childhood friend, Sayori, to join their high school's literature club. The protagonist then meets the other members of the club: Natsuki, Yuri, and the club president Monika. The protagonist starts to participate in the club's activities such as writing and sharing poetry, and grows close to the four girls. What a lovely story!

A very important feature of the game is its poetry writing mechanism. The player is given a list of various words to select from that will make up his poem. Each girl in the Literature Club has different word preferences, and will be very happy if the player's poem is full of her favorite words.

The poem writing mini-game (from wikipedia)

BaoBao is a big fan of the game and likes Sayori the most, so he decides to write a poem to please Sayori. A poem of $m$ words $s_1, s_2, dots, s_m$ is nothing more than a sequence of $m$ strings, and the happiness of Sayori after reading the poem is calculated by the formula $$H = sum_{i=1}^m (m-i+1) cdot f(s_i)$$ where $H$ is the happiness and $f(s_i)$ is Sayori's preference to the word $s_i$.

Given a list of $n$ words and Sayori's preference to each word, please help BaoBao select $m$ words from the list and finish the poem with these $m$ words to maximize the happiness of Sayori.

Please note that each word can be used at most once!

Input

There are multiple test cases. The first line of input contains an integer $T$ (about 100), indicating the number of test cases. For each test case:

The first line contains two integers $n$ and $m$ ($1 le m le n le 100$), indicating the number of words and the length of the poem.

For the following $n$ lines, the $i$-th line contains a string consisting of lowercased English letters $w_i$ ($1 le |w_i| le 15$) and an integer $f(w_i)$ ($-10^9 le f(w_i) le 10^9$), indicating the $i$-th word and Sayori's preference to this word. It's guaranteed that $w_i e w_j$ for all $i e j$.

Output

For each test case output one line containing an integer $H$ and $m$ strings $s_1, s_2, dots, s_m$ separated by one space, indicating the maximum possible happiness and the corresponding poem. If there are multiple poems which can achieve the maximum happiness, print the lexicographically smallest one.

Please, DO NOT output extra spaces at the end of each line, or your answer may be considered incorrect!

sequence of $m$ strings $a_1, a_2, dots, a_m$ is lexicographically smaller than another sequence of $m$ strings $b_1, b_2, dots, b_m$, if there exists a $k$ ($1 le k le m$) such that $a_i = b_i$ for all $1 le i < k$ and $a_k$ is lexicographically smaller than $b_k$.

string $s_1 = a_1a_2dots a_x$ is lexicographically smaller than another string $s_2 = b_1b_2dots b_y$, if there exists a $k$ ($1 le k le min(x, y)$) such that $a_i = b_i$ for all $1 le i < k$ and $a_k < b_k$, or $a_i = b_i$ for all $1 le i le min(x, y)$ and $x < y$.

Sample Input

4
10 8
hello 0
world 0
behind 0
far 1
be 2
spring 10
can 15
comes 20
winter 25
if 200
5 5
collegiate 0
programming -5
zhejiang 10
provincial 5
contest -45
3 2
bcda 1
bcd 1
bbbbb 1
3 2
a 1
aa 1
aaa 1

Sample Output

2018 if winter comes can spring be far behind
15 zhejiang provincial collegiate programming contest
3 bbbbb bcd
3 a aa

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
typedef long long ll;

struct wor{
    string str;
    ll f;
}w[100+5];

bool cmp(wor a,wor b){
    if(a.f>b.f)
        return 1;
    else if(a.f<b.f)
        return 0;
    else{
        return a.str<b.str;
    }
}

int main(){
    int T;
    ios::sync_with_stdio(false);
    cin.tie(0);cout.tie(0);
    while(cin>>T){
        while(T--){
            int m,n;
            cin>>n>>m;
            for(int i=1;i<=n;i++){
                cin>>w[i].str>>w[i].f;
            }
            sort(w+1,w+n+1,cmp);
            ll ans=0;
            string poe="";
            for(int i=1;i<=m-1;i++){
                ans+=1ll*(m-i+1)*w[i].f;
                poe+=w[i].str;
                poe+=' ';
            }
            ans+=w[m].f;
            poe+=w[m].str;
            cout<<ans<<' '<<poe<<endl;
        }
    }
    return 0;
}

  

原文地址:https://www.cnblogs.com/SutsuharaYuki/p/13813370.html