C

FJ's N (1 ≤ N ≤ 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.

FJ has made a list of (0 ≤ R ≤ 10,000) lines of the form "cow 17 sees cow 34". This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.

For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

Input

Line 1: Four space-separated integers: NIH and R 
Lines 2.. R+1: Two distinct space-separated integers A and B (1 ≤ AB ≤ N), indicating that cow A can see cow B.

Output

Lines 1.. N: Line i contains the maximum possible height of cow i.

Sample Input

9 3 5 5
1 3
5 3
4 3
3 7
9 8

Sample Output

5
4
5
3
4
4
5
5
5

思路:用差分数组维护区间的增减,坑点是有可能出现相同区间,如果出现相同的区间就不用处理了,真坑,wa了,用map标记之前是否出现过

其余应该比较简单

代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<vector>
#include<cmath>
#include<set>
#include<stack>
#include<map> 
#define MAX 10005

typedef long long ll;

using namespace std;

map<int,int>mp;
int a[MAX];
int d[MAX];
int vis[1000005];
int main()
{
	int N,I,H,R;
	cin>>N>>I>>H>>R;
	for(int t=1;t<=N;t++)
	{
		a[t]=H;
	}
	for(int t=1;t<=N;t++)
	{
		d[t]=a[t]-a[t-1];
	}
	int l,r;
	for(int t=0;t<R;t++)
	{
		scanf("%d%d",&l,&r);
		if(max(l,r)-min(l,r)>=2&&mp[l]!=r)
		{
			d[min(l,r)+1]--;
			d[max(l,r)]++;
		    mp[l]=r;
		}
	}

	for(int t=1;t<=N;t++)
	{
		a[t]=a[t-1]+d[t];
	}
    for(int t=1;t<=N;t++)
    {
    	cout<<a[t]<<endl;
	}
    return 0;
}
原文地址:https://www.cnblogs.com/Staceyacm/p/10781798.html