POJ 2533 动态规划入门 (LIS)

Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 42914 Accepted: 18914
Description

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input

7
1 7 3 5 9 4 8
Sample Output

4

一个裸的 LIS
直接给状态转移方程: if (a[j]>a[i]) f[j]=max(f[j],f[i]+1);

#include <cstdio>
#include <algorithm>
using namespace std;
int n,a[1005],f[1005];
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        scanf("%d",&a[i]); 
    for(int i=1;i<=n;i++)
        for(int j=i;j<=n;j++)
            if(a[j]>a[i])   f[j]=max(f[i]+1,f[j]);
    for(int i=1;i<=n;i++)
        f[0]=max(f[0],f[i]);
    printf("%d",f[0]+1);//因为是从0开始的 所以要+1
}

还是0msAC的

原文地址:https://www.cnblogs.com/SiriusRen/p/5831199.html