动态规划1002

题目大意:最长公共子序列

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = &lt;x1, x2, ..., xm&gt; another sequence Z = &lt;z1, z2, ..., zk&gt; is a subsequence of X if there exists a strictly increasing sequence &lt;i1, i2, ..., ik&gt; of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = &lt;a, b, f, c&gt; is a subsequence of X = &lt;a, b, c, f, b, c&gt; with index sequence &lt;1, 2, 4, 6&gt;. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. <br>The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. <br>
 
Sample Input
abcfbc abfcab programming contest abcd mnp
 
Sample Output
4 2 0
解题思路:
将两个序列化成矩阵,依次匹配,F[i][j]=F[i-1][j-1]+1;(a[i]==b[j])
F[i][j]=max(F[i-1][j],F[i][j-1])(a[i]!=b[j]);
n由于F(i,j)只和F(i-1,j-1), F(i-1,j)和F(i,j-1)有关, 而在计算F(i,j)时, 只要选择一个合适的顺序, 就可以保证这三项都已经计算出来了, 这样就可以计算出F(i,j). 这样一直推到f(len(a),len(b))就得到所要求的解了.
代码:
#include<iostream>  
#include<string.h>  
#include<algorithm>  
using namespace std;  
int dp[1005][1005];  
int main()  
{  
    int n,i,j;  
  
    string s1,s2;  
    char arr[1005];  
  
    while(~scanf("%s",arr))  
    {  
        s1=arr;  
        scanf("%s",arr);  
        s2=arr;  
        memset(dp,0,sizeof(dp));  
  
        for(i=0;i<s1.length();i++)  
        {  
            for(j=0;j<s2.length();j++)  
            {  
                if(s1[i]==s2[j])  
                {  
                    dp[i+1][j+1]=dp[i][j]+1;  
                }  
                else  
                {  
                    dp[i+1][j+1]=max(dp[i][j+1],dp[i+1][j]);  
                }  
            }  
        }  
        cout<<dp[s1.length()][s2.length()]<<endl;  
  
    }  
} 
原文地址:https://www.cnblogs.com/Sikaozhe/p/5468659.html