P3378 堆【模板】 洛谷

https://www.luogu.org/problem/show?pid=3378

题目描述

如题,初始小根堆为空,我们需要支持以下3种操作:

操作1: 1 x 表示将x插入到堆中

操作2: 2 输出该小根堆内的最小数

操作3: 3 删除该小根堆内的最小数

输入输出格式

输入格式:

第一行包含一个整数N,表示操作的个数

接下来N行,每行包含1个或2个正整数,表示三种操作,格式如下:

操作1: 1 x

操作2: 2

操作3: 3

输出格式:

包含若干行正整数,每行依次对应一个操作2的结果。

输入输出样例

输入样例#1:
5
1 2
1 5
2
3
2
输出样例#1:
2
5

说明

时空限制:1000ms,128M

数据规模:

对于30%的数据:N<=15

对于70%的数据:N<=10000

对于100%的数据:N<=1000000(注意是6个0。。。不过不要害怕,经过编者实测,堆是可以AC的)

样例说明:

故输出为2、5

#include <algorithm>
#include <iostream>
#include <cstdio>

using namespace std;

int n,m,x,size;
int heap[1000005];

void push(int x)
{
    int now,next;
    heap[++size]=x;
    now=size;
    while(now>1)
    {
        next=now/2;
        if(heap[next]<=heap[now])    break;
        swap(heap[next],heap[now]);
        now=next;
    }
}

void pop()
{
    heap[1]=heap[size--];
    int now=1,next;
    while(now*2<=size)
    {
        next=now*2;
        if(next<size&&heap[next]>heap[next+1])    next++;
        if(heap[next]>=heap[now])    break;
        swap(heap[next],heap[now]);
        now=next;
    }
}

int main()
{
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d",&m);
        if(m==1)
        {
            scanf("%d",&x);
            push(x);
        }
        if(m==2)
            cout<<heap[1]<<endl;
        if(m==3)
            pop();
    } 
    return 0;
}
——每当你想要放弃的时候,就想想是为了什么才一路坚持到现在。
原文地址:https://www.cnblogs.com/Shy-key/p/6486371.html