Agri-Net

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.
Input
The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.
Output
For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.
Sample Input
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
Sample Output
28
简单的prime,第一次接触,有点蒙蒙的,不是太懂他的原理,题的意思也不太明白,看着每个人的博客,都说是裸的prime,但是一点不去描述题目,(可能是自己的外语太差了),发现自己差的不是算法
是题,根本没有理解样例是用来干什么的,直到我知道了,每行数都是代表第几个农场到其他农场的距离,这样这道题就很清晰明了了,认真对待每一道题。。。。
附代码
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
int v[101],m[101];
int data[101][101];
int prime(int cost[][101],int num)
{
    int min,node,sum=0;
    memset(v,0,sizeof(v));//初始化数组v,数组v表示点
    v[0]=1;//令第一个为1
    for(int i=0; i<num; i++)
        m[i]=cost[0][i];//将数组m初始化为二维数组的第一行数字
    for(int i=1; i<num; i++)
    {
        min=10000000;//设置一个超大最小值
        node=-1;//标志
        for(int j=1; j<num; j++)
            if(v[j]==0&&m[j]<min)
            {//如果数组元素v等于0且数组元素m值小于最小值,就更新最小值与node
                min=m[j];
                node=j;
            }
        v[node]=1;
        sum+=min;
        for(int j=1; j<num; j++)
            if(v[j]==0&&m[j]>cost[node][j])
                m[j]=cost[node][j];
    }
    return sum;
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                scanf("%d",&data[i][j]);
        printf("%d ",prime(data,n));
    }
    return 0;
}
就这样。

原文地址:https://www.cnblogs.com/She-Chuan/p/9692583.html