All in All ( UVA

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
Input
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.
Output
For each test case output, if s is a subsequence of t.
Sample Input
sequence subsequence person compression VERDI vivaVittorioEmanueleReDiItalia caseDoesMatter CaseDoesMatter
Sample Output
Yes No Yes No

Select Code
#include <bits/stdc++.h>
using namespace std;

int main()
{
    string str,sub;
    int sum=0,ans=0;
    while(cin>>sub>>str)
    {
        int j=0,ans=0,k=0;
        for(int i=0;i<sub.size();i++)
        {
            for(;j<str.size();j++)
            {
                if(sub[i]==str[j]) {j++;ans++;break;}
            }
            if(ans==sub.size()) {cout<<"Yes"<<endl;k=1;}
        }
        if(!k) cout<<"No"<<endl;
    }
    return 0;
}
所遇皆星河
原文地址:https://www.cnblogs.com/Shallow-dream/p/11632270.html