浙大pat甲级题目---1032. Sharing (25)

1032. Sharing (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.


Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Nextis the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1
题目大意:就是寻找共享的节点
题目解法:我原本的想法是分离第一个单词和第二个单词,然后遍历查找第二个单词和第一个单词重复的部分。这方法太笨了,最后两个测试点超时。
后来看了一个题解,发现人家解法精妙,代码很短。简单来说就是用数组存,每个node有一个flag变量用来查看是否遍历过。
首先按链表顺序访问word1,将其标为true,再访问第二个。
我居然没想到。。。
https://blog.csdn.net/sy_yu/article/details/54909198
这是代码地址,我也copy一下贴出来吧
#include<stdio.h>

#define MAX_N 1000100

struct Node{
    char data;
    int next;
    bool flag;//用flag遍历一遍就好
}node[MAX_N];

void init(){
    for(int i=0;i<MAX_N;i++){
        node[i].flag=false;
    }
}

int main(){
    init();
    int n;
    int l1,l2;
    int address,next;
    char data;
    int p;
    scanf("%d%d%d",&l1,&l2,&n);

    for(int i=0;i<n;i++){
        scanf("%d %c %d",&address,&data,&next);
        node[address].data=data;
        node[address].next=next;
    }
    for(int i=l1;i!=-1;i=node[i].next){
        node[i].flag=true;
    }
    for(p=l2;p!=-1;p=node[p].next){
        if(node[p].flag)
            break;
    }
    if(p!=-1)
        printf("%05d",p);
    else
        printf("-1");
}
原文地址:https://www.cnblogs.com/SK1997/p/8679250.html