每日一练ACM 2019.0416

2019.04.16
 
 
Problem Description
Your task is to Calculate the sum of some integers.
 

Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
 

Sample Input
4 1 2 3 4
5 1 2 3 4 5 0
 

Sample Output
10
15
 
 
import java.util.Scanner;

public class Acm20190416 {
    public static void main(String[] args)
    {
        Scanner input=new Scanner(System.in);
        while(input.hasNext())
        {
            int n=input.nextInt();
            if(n==0) break;
            else
            {
                int[] a=new int[n];
                for(int i=0;i<n;i++)
                {
                    a[i]=input.nextInt();
                }
                int sum=0;
                for(int j=0;j<a.length;j++)
                {
                    sum+=a[j];
                }
                System.out.println(sum);
            }
            
        }
    }

}
原文地址:https://www.cnblogs.com/SGRBOY/p/10720463.html