HDU1250 高精度斐波那契数列

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10568    Accepted Submission(s): 3507


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

 

Input
Each line will contain an integers. Process to end of file.
 

 

Output
For each case, output the result in a line.
 

 

Sample Input
100
 

 

Sample Output
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
 

 

Author
戴帽子的
 

 

Recommend
Ignatius.L
#include <iostream>
#include <stdio.h>
using namespace std;
int a[10000][260]={0};
int main()
{
    int i,j,n;
    a[1][0]=1;
    a[2][0]=1;
    a[3][0]=1;
    a[4][0]=1;
    for(i=5;i<10000;i++)
    { 
        for(j=0;j<260;j++)
        {
            a[i][j]+=a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j];
            a[i][j+1]+=a[i][j]/100000000;
            a[i][j]=a[i][j]%100000000;
        }
    }
    while(cin>>n)
    {
        for(j=259;j>=0;j--)
        if(a[n][j]!=0)
        break;
        cout<<a[n][j];
        for(j=j-1;j>=0;j--)
        printf("%08d",a[n][j]); //不能直接cout 数大的时候是错的 因为可能会输出七位 正常应该输出八位的 反正就是不对
        cout<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/Ritchie/p/5425324.html