HDU1005&&NEFU67 没有循环节

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 147161    Accepted Submission(s): 35755


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 
Output
For each test case, print the value of f(n) on a single line.
 
Sample Input
1 1 3 1 2 10 0 0 0
 
Sample Output
2 5
 
Author
CHEN, Shunbao
 
Source
 
Recommend
JGShining   |   We have carefully selected several similar problems for you:  1008 1021 1019 1012 1108 
#include <string.h>
#include <iostream>
#include <algorithm>
#include <stdlib.h>
#include <stdio.h>
using namespace std;
int main()
{
    int a,b,n,i,data[1005];
    while (cin>>a>>b>>n&&a&&b&&n)
    {
        data[1]=1;
        data[2]=1;
        for (i=3;i<=1000;i++)
        {
            data[i]=((a*data[i-1]%7)+((b*data[i-2]%7%7)))%7;
            if (data[i-1]==1&&data[i]==1) //if(data[i-1])意思是只要是正数就行
            break;
        }
        data[0]=data[i-2];
        cout<<data[n%(i-2)]<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/Ritchie/p/5425314.html