1003. Emergency (25)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4




这道题没能完全通过,有一个测试点始终没办法通过...问了大神大神还没回复我,后续可能会更新

照样记录出错的过程:
1.图是无向图,忘记使g.edge[i][j]=g.edge[j][i]=weight;
2.需要减枝,确定了目标的最短路径后就需要停止循环了
3.最短路径的条数的计算有问题,没有考虑到如果1-2有3条,那么1-2-4的时候4要考虑上2的3条
if(相等)
countpath[i]=countpath[i]+countpath[k];
if(小于)
countpath[i]=countpath[k]


 #include<iostream>
  using namespace std;
  #define MAX 10000000
  #define MAX_VERTEX_NUM 505
    int count1[MAX_VERTEX_NUM];
    int dist[MAX_VERTEX_NUM];
    int path[MAX_VERTEX_NUM];
    typedef struct
    {
        int vexs[MAX_VERTEX_NUM];
        int edges[MAX_VERTEX_NUM][MAX_VERTEX_NUM];
        int vexnum,edgenum;
    }MGraph;

    void CreateDN_AM(MGraph &G,int n,int e)
    {
        G.vexnum=n;
        G.edgenum=e;

        int i,j,k;
        int weight;
        for(i=0;i<n;i++)
            cin>>G.vexs[i];
        for(i=0;i<n;i++)
            for(j=0;j<n;j++)
                G.edges[i][j]=MAX;
        for(k=0;k<e;k++)
        {
            cin>>i>>j>>weight;
            G.edges[i][j]=G.edges[j][i]=weight;
        }
    }

    void ShortestPath_DJ(MGraph &G,int v,int t)
    {
        int i,j,k,min;

        int final[MAX_VERTEX_NUM];

        for(i=0;i<G.vexnum;i++)
        {
            dist[i]=G.edges[v][i];
            if(dist[i]<MAX)
                path[i]=G.vexs[v]+G.vexs[i];
            else
                path[i]=0;
            final[i]=0;
            count1[i]=1;
        }
        dist[v]=0;
        final[v]=1;
        for(j=1;j<G.vexnum;j++)
        {
            min=MAX;
            for(i=0;i<G.vexnum;i++)
                if(dist[i]<min && final[i]==0)
                {
                    min=dist[i];
                    k=i;
                }
            if(k==t) break;
            final[k]=1;
            for(i=0;i<G.vexnum;i++)
            {
                if(dist[i]>dist[k]+G.edges[k][i] && final[i]==0)
                {
                    dist[i]=dist[k]+G.edges[k][i];
                    path[i]=path[k]+G.vexs[i];
                    count1[i]=count1[k];
                }
                else if(dist[i]==dist[k]+G.edges[k][i]&&final[i]==0){
                    count1[i]=count1[i]+count1[k];
                    if(path[i]<path[k]+G.vexs[i]){
                        path[i]=path[k]+G.vexs[i];
                    }
                }
            }
        }
    }

    int main()
    {
        MGraph G;
        int n,m,s,t;
        cin>>n>>m>>s>>t;
        CreateDN_AM(G,n,m);
        ShortestPath_DJ(G,s,t);
        cout<<count1[t]<<" "<<path[t];
    }

更新更新:

出错的那一个测试点是因为没有考虑到当起点和目标是同一个城市的情况(真是奇怪..)

这样的话直接输出1和这个城市的救援队数量。

加了一句这个就过了

        if(s==t){
            cout<<'1'<<" "<<G.vexs[s];
        }
原文地址:https://www.cnblogs.com/Qmelbourne/p/6057087.html