POJ 2796 Feel Good

传送门

Time Limit: 3000MS  Memory Limit: 65536K
Case Time Limit: 1000MS  Special Judge
 

Description

Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life.

A new idea Bill has recently developed assigns a non-negative integer value to each day of human life.

Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day.

Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

Input

The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 106 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

Output

Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

Sample Input

6
3 1 6 4 5 2

Sample Output

60
3 5

Source


Solution
单调栈

Implementation
#include <cstdio>
#include <stack>
#include <iostream>
using namespace std;
typedef long long LL;

const int N(1e5+5);

int h[N], L[N], R[N], st[N];
LL s[N];

int main(){
    int n;
    scanf("%d", &n);
    for(int i=1; i<=n; i++) scanf("%d", h+i);
    for(int i=1; i<=n; i++) s[i]=s[i-1]+h[i];
    // (L[i], R[i]]
    int t=-1;    //top of stack
    for(int i=1; i<=n; i++){
        for(; ~t && h[st[t]]>=h[i]; t--);
        L[i]=~t?st[t]:0;    //error-prone
        st[++t]=i;
    }
    t=-1;
    for(int i=n; i; i--){
        for(; ~t && h[st[t]]>=h[i]; t--);
        R[i]=~t?st[t]-1:n;
        st[++t]=i;
    }
    LL res=-1;    //error-prone
    int l, r;
    for(int i=1; i<=n; i++){
        LL t=h[i]*(s[R[i]]-s[L[i]]);
        if(t>res){
            res=t;
            l=L[i]+1, r=R[i];
        }
    }
    printf("%lld
%d %d
", res, l, r);
    return 0;
}

代码里标error-prone的地方都是坑,请特别注意。

尤其 res应初始化成-1,因为"A new idea Bill has recently developed assigns a non-negative integer value to each day of human life."

原文地址:https://www.cnblogs.com/Patt/p/5068037.html