Immediate Decodability问题Java解答

Description
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:

A:01 B:10 C:0010 D:0000

but this one is not:

A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input
Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

The Sample Input describes the examples above.

Sample Input
01
10
0010
0000
9
01
10
010
0000
9
Sample Output
Set 1 is immediately decodable
Set 2 is not immediately decodable
HINT

import java.util.Scanner;
class Trie{
    class Node{//字典树节点
        Node nxt[]=new Node[10];//儿子节点
        boolean end=false;//是否是一个二进制代码的最后一个节点
        int count=0;//此节点上通过的字符(数字)个数
    }
 
    Node head=null;//字典树的根节点
 
     void clear(){
       head=new Node();
   }
    boolean insert(String str)
    {//构造字典树
        Node p=head;
        for(int i=0;i< str.length();i++){          
   p.count++;           
  if(p.end) return false;//存在前缀    
         if(p.nxt[str.charAt(i)-'0']==null)               
  p.nxt[str.charAt(i)-'0']=new Node();           
  p=p.nxt[str.charAt(i)-'0'];        
 }       
  p.count++;       
  if(p.count>1) return false;//存在前缀
        p.end=true;
       return true;
    }
 
    public static void main(String[] args) 
    {
        Trie tree=new Trie();
        Scanner in=new Scanner(System.in);
        int count=0;
        while(in.hasNext())
        {
             String s = in.next();  
             count++;  
             tree.clear();  
             int  flag=0;
            while (!s.equals("9")) {  
                if(!tree.insert(s)) flag++;  
                s = in.next();  
            }  
           if (flag!=0) {// 如果存在前缀,输出
              System.out.println("Set "+count+" is not immediately decodable");                          
            }  
            else {// 如果不存在前缀,输出   
             System.out.println("Set " +count+" is immediately decodable");  
            }  
        }  
    }
}
原文地址:https://www.cnblogs.com/NYNU-ACM/p/4236891.html