Problem C: Andy's First Dictionary

Problem C: Andy’s First Dictionary
Time Limit: 1 Sec Memory Limit: 128 MB
Submit: 18 Solved: 5
[Submit][Status][Web Board]
Description
Andy, 8, has a dream – he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like “Apple”, “apple” or “APPLE” must be considered the same.

Input
The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

Output
Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

Sample Input
Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: “Disneyland Left.”

So they went home.
Sample Output
a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when
my answer:

#include<iostream>
#include<algorithm>
#include<stdlib.h>
#include<cmath>
#include<stdio.h>
#include<cstring>
#include<string>
using namespace std;
char * dtox(char a[])//函数。。。由大写转化成小写 ;
{
    int t1=strlen(a);
    for (int i=0;i!=t1;i++)
        if(a[i]>='A'&&a[i]<='Z')
            a[i]=a[i]+32;
        return a;
}
char * quza(char b[])//函数。。。去掉符号部分;
{
    int t2=strlen(b);
    char s[1000];
    int f=0;
    dtox(b);
    for(int j=0;j!=t2;j++){
        if(b[j]>='a'&&b[j]<='z')
            s[f++]=b[j];
    }
    s[f]='';
    return s;
}
int main()
{
 
    char a[100][100],word[100][100];
    int i=0,k=0;
    while(gets(a[i]))
    {
        int t=strlen (a[i]);
        if(t==0)
            continue;
        char *p;
        p=strtok(a[i]," ");
        while(p)
        {
           strcpy(word[k++],quza(p));
           p=strtok(NULL," ");
        }
 
        i++;
    }
    //sort (word[0],word[0]+k);
    for(int t=0;t!=k;t++){
        int w=t;
        for(int m=t;m!=k;m++)
        if(strcmp(word[w],word[m])>0)w=m;
        char r[1000];
        strcpy(r,word[w]);
        strcpy(word[w],word[t]);
        strcpy(word[t],r);
    }
    for (int h=0;h!=k;h++){
            if(strcmp(word[h],word[h+1]))
               cout <<word[h]<<endl;
    }
         return 0;
}
原文地址:https://www.cnblogs.com/NYNU-ACM/p/4236886.html