POJ3207 Ikki's Story IV

题目

liympanda, one of Ikki’s friend, likes playing games with Ikki. Today after minesweeping with Ikki and winning so many times, he is tired of such easy games and wants to play another game with Ikki.

liympanda has a magic circle and he puts it on a plane, there are n points on its boundary in circular border: 0, 1, 2, …, n − 1. Evil panda claims that he is connecting m pairs of points. To connect two points, liympanda either places the link entirely inside the circle or entirely outside the circle. Now liympanda tells Ikki no two links touch inside/outside the circle, except on the boundary. He wants Ikki to figure out whether this is possible…

Despaired at the minesweeping game just played, Ikki is totally at a loss, so he decides to write a program to help him.

输入格式

The input contains exactly one test case.

In the test case there will be a line consisting of of two integers: n and m (n ≤ 1,000, m ≤ 500). The following m lines each contain two integers ai and bi, which denote the endpoints of the ith wire. Every point will have at most one link.

输出格式

Output a line, either “panda is telling the truth...” or “the evil panda is lying again”.

输入样例

4 2
0 1
3 2

输出样例

panda is telling the truth...

题解

2-sat裸题
如果两条连线的区间有相交,那么就不能同时在圆的一侧

#include<iostream>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define LL long long int
#define REP(i,n) for (int i = 1; i <= (n); i++)
#define Redge(u) for (int k = h[u],to; k; k = ed[k].nxt)
#define BUG(s,n) for (int i = 1; i <= (n); i++) cout<<s[i]<<' '; puts("");
using namespace std;
const int maxn = 1005,maxm = 1000005,INF = 1000000000;
inline int read(){
	int out = 0,flag = 1; char c = getchar();
	while (c < 48 || c > 57) {if (c == '-') flag = -1; c = getchar();}
	while (c >= 48 && c <= 57) {out = (out << 3) + (out << 1) + c - '0'; c = getchar();}
	return out * flag;
}
int n,m,h[maxn],ne = 0;
struct EDGE{int to,nxt;}ed[maxm];
inline void build(int u,int v){
	ed[ne] = (EDGE){v,h[u]}; h[u] = ne++;
}
struct node{int l,r;}e[maxn];
inline bool operator <(const node& a,const node& b){
	return a.l == b.l ? a.r < b.r : a.l < b.l;
}
int dfn[maxn],low[maxn],Scc[maxn],scci = 0,cnt = 0,st[maxn],top = 0;
void dfs(int u){
	dfn[u] = low[u] = ++cnt;
	st[++top] = u;
	Redge(u)
		if (!dfn[to = ed[k].to])
			dfs(to),low[u] = min(low[u],low[to]);
		else if (!Scc[to]) low[u] = min(low[u],dfn[to]);
	if (dfn[u] == low[u]){
		scci++;
		do{Scc[st[top]] = scci;}while (st[top--] != u);
	}
}
int main(){
	while (~scanf("%d%d",&n,&m)){
		REP(i,m){
			e[i].l = read(),e[i].r = read();
			if (e[i].l > e[i].r) swap(e[i].l,e[i].r);
		}
		sort(e + 1,e + 1 + m);
		for (int i = 1; i <= m; i++)
			for (int j = i + 1; j <= m; j++)
				if (e[j].l <= e[i].r && e[j].r >= e[i].r){
					build(2 * i,2 * j - 1),build(2 * j,2 * i - 1);
					build(2 * i - 1,2 * j),build(2 * j - 1,2 * i);
				}
				else break;
		for (int i = 1; i <= (m << 1); i++) if (!dfn[i]) dfs(i);
		bool flag = true;
		for (int i = 1; i <= m; i++) if (Scc[2 * i] == Scc[2 * i - 1]){
			flag = false; break;
		}
		if (flag) puts("panda is telling the truth...");
		else puts("the evil panda is lying again");
	}
	return 0;
}

原文地址:https://www.cnblogs.com/Mychael/p/8283237.html