Expedition

Expedition

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

Source

 
 
------------------------------------------------------------------------------------------------------------------------------------------
 
思想:
贪心的思想。这里利用了STL中的大顶堆Q,每次经过一个站点,就把这个站点能加的油的数量push进Q,当我的油不足以到达下一个站点时,且此时Q也不为空的话,就从堆顶取出最大的加油量,如果Q为空了我也到不了下个站点,那就over了。
 
要注意的地方:
 1. 这里从控制台input的距离是终点离站点的距离,我要把它转化成起点到站点的距离;
 2. 输入的站点时无序的,我得根据站点和起点的距离sort一下;
 3. 见注释 
 
Source Code:
#include <iostream>
#include <queue>
#include <algorithm>

using namespace std;

struct Status{
    int Distance;
    int fuelAmount;
    int DisToTown;
};

Status Stops[10010];

bool cmp(Status a,Status b){
    return a.Distance<=b.Distance;
}

int main()
{
    int N,L,P;
    int tank,currentDis,currentLoc;
    priority_queue<int> Q;
    bool haveAnswer;
    int answer;
    while(cin>>N){
        for(int i=0;i<N;++i){
            cin>>Stops[i].DisToTown>>Stops[i].fuelAmount;
        }
        cin>>L>>P;
        for(int i=0;i<N;++i){
            Stops[i].Distance=L-Stops[i].DisToTown;
        }
        Stops[N].Distance=L;  //很关键的一步:把终点也当做一个站点,只是这个站点的fuelAmount等于0,
                              //所以后面的for循环i从0到N,要不然的话只是计算了到最后一个站点要加几次油。
        Stops[N].fuelAmount=0;
        sort(Stops,Stops+N,cmp);
        while(Q.empty()==false)
            Q.pop();
        tank=P;
        currentLoc=0;
        haveAnswer=true;
        answer=0;
        for(int i=0;i<=N;++i){
            currentDis=Stops[i].Distance-currentLoc;
            while(tank<currentDis){
                if(Q.empty()){
                    cout<<-1<<endl;
                    haveAnswer=false;
                    break;
                }else{
                    tank+=Q.top();
                    Q.pop();
                    ++answer;
                }
            }
            tank-=currentDis;
            currentLoc=Stops[i].Distance;
            Q.push(Stops[i].fuelAmount);
        }
        if(haveAnswer)
            cout<<answer<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/Murcielago/p/4222358.html