Hdoj 1087.Super Jumping! Jumping! Jumping!

Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.
img
The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

Author

lcy


思路

(f[i])表示到位置(i)的最大和,显然状态转移方程为:

(f[i] = max(f[j])+a[i](i:1→n;j:1→i-1))

代码

#include<bits/stdc++.h>
using namespace std;
int a[1001];
int f[1001];
int main()
{
	int n;
	while(cin>>n&&n!=0)
	{
		for(int i=1;i<=n;i++)
			cin >> a[i];
		int maxvalue = -1;
		memset(f,0,sizeof(f));
		
		for(int i=1;i<=n;i++)
		{
			int tmp = 0;
			for(int j=1;j<i;j++)
			{
				if(a[i] > a[j])
					tmp = max(tmp,f[i]);
			}
			f[i] += a[i] + tmp;		//因为前面已经有a[i]>a[j]都逐个检验,所以这个a[i]一定是前面某个序列的最后一项
			maxvalue = max(maxvalue, f[i]);
		}
		cout << maxvalue << endl;
	}
			
	return 0;
}
原文地址:https://www.cnblogs.com/MartinLwx/p/9829741.html