PTA(Advanced Level)1050.String Subtraction

Given two strings S1 and S2, S=S1−S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1−S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1−S2 in one line.

Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.
思路
  • map容器,记录S1的字符,再扫描一遍S2,确定不可用的字符
  • 最后扫描一遍S1,如果对应的字符可用就输出
代码
#include<bits/stdc++.h>
using namespace std;

int main()
{
	string s1, s2;
	getline(cin, s1);
	getline(cin, s2);
	map<char,int> mp;
	for(int i=0;i<s1.size();i++)
		if(mp.count(s1[i]) == 0)
			mp[s1[i]] = 1;
	for(int i=0;i<s2.size();i++)
		if(mp.count(s2[i]) == 0)  //该字符根本没有在s1中出现过
			continue;
		else
			mp[s2[i]] = 0;   //标记为0表示不可用
	for(int i=0;i<s1.size();i++)
		if(mp[s1[i]] != 0)
			cout << s1[i];
	return 0;
}
引用

https://pintia.cn/problem-sets/994805342720868352/problems/994805429018673152

原文地址:https://www.cnblogs.com/MartinLwx/p/11896354.html